ONESOFTDIGM, Close

Contents

FAQ

Welcome to OSD Support. We’re here to help.

ONESOFTDIGM - FAQ - Fitrus Plus

ONESOFTDIGM - FAQ - Fitrus Plus

Top left bar > Settings > Sync > choose between Health App, Fitrus+, and All Step
Fitrus App offers Korea, Japan, and English.
We are in a process of offering more language options.
Fitrus+ is compatible with Android 5.0 or above, and iOS 9.0 or above.
However, some Androids and iPads will not be compatible.
Search